SECURITY ANNOUNCEMENT: Removing Old TLS Versions

On Tuesday, January 21, 2020, Smarty will reqsuire clients to use TLSv1.2 or greater to connect with Smarty APIs without interruption.
Subscribe Now
October 17, 2019
by Jonathan Oliver

TLS (and its predecessor SSL) are cryptographic protocols that provide authentication and data encryption for clients connecting with web servers. As new vulnerabilities are discovered, older cryptographic protocol versions are deprecated to maintain secure environments.

On Tuesday, January 21, 2020, Smarty (formerly SmartyStreets) will require clients to use TLSv1.2 or greater to connect with Smarty APIs without interruption. Clients using TLSv1.0 or TLSv1.1 will no longer be able to connect. Please refer to our documentation for more information: https://www.smarty.com/docs/cloud/requirements#ciphers

To see if your client software is able to properly connect, please use our test page: https://test-tls.api.smartystreets.com/


The industry in general is removing support for older TLS versions. Please refer to the following announcements from major browser vendors for more information:

The leader in location data intelligence

Ready to get started?